Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Share Me

  • Please share this topic with your friends. Click any of the icons below:
  • Twitter
  • facebook
  • reddit
  • email

C++Builder XE6 and SyntaxEdit

I tried installing SyntaxEdit for C++Builder XE6 and when I loaded C++Builder I got errors like these:

lmdrtl200.bpl is missing from your computer
Can't load package dcllmdrtl200.bpl
...
and similar

I see the bpl files in the folder where I installed it: "...\LMD2014\packages\lmdrtl200.bpl"

Bad installer? Any ideas?

Comments

  • 5 Comments sorted by Votes Date Added
  • Here are a couple of screenshots that might shed some light...

    Strange... they didn't upload... just froze on 'Uploading...'.

    Anyway, one shows the 'Package Installation Options' installer screen with 'Install packages to' and the option for the default BPL output directory is empty (nothing shows in the parenthesis). I tried the XE installer and it shows $(BDSCOMMONDIR)\Bpl. Note that I have RAD Studio XE but only C++Builder XE6 (not RAD Studio XE6).

    Also, I get an error when I click on the 'LMD Wiki' button.
  • I got it to work by manually entering the proper BPL path that the installer did not seem to pick up... in my case it was: "C:\Users\Public\Documents\Embarcadero\Studio\14.0\BPL"
  • Hi,

    thanks for feedback. Such errors always have the same cause and can be fixed by following the instructions available at:
  • edited May 2014 Posts: 81Vote Up0Vote Down
    Thanks. I might have seen that if the 'LMD Wiki' button worked but it didn't work for me. I got a "Class not registered" error but the error message does seem to show the right URL but I didn't bother to type it in....

    I still think the installer could do a better job at determining the default BPL path... perhaps it's an issue related to me using C++Builder, which doesn't seem to get as much attention as Delphi.
Sign In or Register to comment.